آموزش سازگاری قالب با ووکامرس

سازگاری قالب با ووکامرس

نوع آموزش : آموزش افزونه

دسته بندی آموزش : آموزش افزونه های ووکامرس

تاریخ آپدیت و بروز رسانی : سه شنبه، ۲۳ بهمن ۱۳۹۷

سازگاری قالب با ووکامرس یکی از اساسی ترین کار در سایتهای فروشگاهی هست

وقتی که افزونه ووکامرس را در سایت فروشگاهی وردپرسی خود نصب می کنید در هر آپدیتی که در قالب افزونه انجام می گرد.

در بخش پیشخوان قالب وردپرسی پیغام خطایی مبنی بر اینکه پوسته شما دارای الگوهای قدیمی ووکامرس می باشد یا قالب شما از چند فایل ووکامرس قدیمی استفاده می کند.

که علت وجود این پیغام خطا بدلیل ناهماهنگی بین قالب نصب شده وردپرسی شما با افزونه ووکامرس هست .

در این بخش از پایگاه دانش وردپرس سبز قبل از اینکه به پیغام خطا  در بخش پیشخوان وردپرس با عنوان پوسته شما دارای فایلهای الگوی قدیمی ووکامرس می باشد بپردازیم نحوه سازگاری قالب با ووکامرس را برای شما بیان می کنیم .

آموزش رفع پیغام خطای سازگاری قالب با ووکامرس :

وقتی که شما افزونه ووکامرس را دانلود می کنید در داخل پوشه ووکامرس پوشه ای با عنوان templates یا قالب قرار دارد و فایلهای داخل این پوشه مسئول هماهنگ کردن قالب با افزونه ووکامرسی هست . به تصویر زیر دقت کنید:

آموزش سازگاری قالب با ووکامرس
سازگاری قالب با ووکامرس
آموزش سازگاری قالب با ووکامرس
سازگاری قالب با ووکامرس

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

همانطور که در تصویر فوق مشاهده می کنید فایلهای داخل پوشه template را نشان می دهد .

حال اگر به قسمت پوشه قالب خودتون در هاست مراجعه کنید اگر قالب سایت شما از ووکامرس پشتیبانی کند در داخل پوشه قالب سایت خود پوشه ای با نام woocommerce مشاهده خواهید کرد به تصویر زیر دقت نمایید :

سازگاری قالب با ووکامرس
سازگاری قالب با ووکامرس

با کلیک بر روی پوشه woocommerce پوشه ای به نام global  را مشاهده خواهید کرد که با باز کردن این پوشه دو فایل به نامهای wrapper-start.php و  wrapper-end.php مشاهده خواهید کرد .

و علت این خطا بدلیل ناهماهنگی زمان آپدیت شده افزونه ووکامرس و قالب وردپرسی شما هست و زمانی که فایلهای ووکامرسی به ورژن جدید آپدیت می شود

ممکن است هنوز فایلهای داخل پوسته یا قالب وردپرسی شما توسط طراح قالب با افزونه ووکامرس هماهنگ و آپدیت نشده باشد و همین مورد سبب بروز این خطا می گردد .

به همین خاطر به هنگام بروز رسانی افزونه ووکامرس با خطای پوسته شما دارای الگوهای قدیمی ووکامرس می باشد مواجه خواهید شد.

برای رفع این خطا می بایستی فایلهای داخل پوشه ووکامرس افزونه را که در بالا ذکر شد شاملwrapper-start.php و  wrapper-end.php را جایگزین فایلهای داخل پوشه ووکامرس قالب خود نمایید .

و بعد از این با رفرش صفحه پیشخوان وردپرسی خود ( برای رفرش کلیدهای ترکیبی ctrl+f5 را بزنید ) مشاهده خواهید کرد که پیغام خطا از بین رفته و سازگاری قالب با ووکامرس کاملاً انجام گرفته است .

تذکر مهم : لازم و ضروری هست قبل از جایگزینی فایلها حتماً از فایلهای ووکامرس افزونه و قالب سایت خود یک کپی داشته باشید

تا در صورتیکه به هر دلیل جایگزینی فایلها دچار مشکل گردید بتوانید آن مشکل را برطرف کنید.

توصیه می شود قبل از هر کاری یک فول بکاپ از هاست خود بگیرید تا بتوانید در مواقع وجود مشکل اطلاعات هاست خود را مجدداً به حالت قبل از خرابی بازگردانی کنید .

شاید مطالعه این مطلب هم برای شما مفید باشد : بهترین افزونه آمار بازدید از سایت همراه با آموزش تصویری wpstatistics

ضمناً می بایستی هر کدام از فایلهای ووکامرس  را که جایگزین فایلهای قالب می کنید می بایستی بصورت مجزا و تک تک انجام گیرد .

امیدواریم این آموزش هم برای شما مفید واقع شده باشد و بتوانید مشکل خطا را به راحتی رفع نمایید .

 

 

 

 

 

 

بازدید: ۰

دوست خوبم لطفا با ثبت نظرات خود ما را در کامل تر کردن وردپرس سبز یاری فرمائید.

  پیگیری پاسخ های داده شده به این دیدگاه  
اشاره به موضوع